BF130 problems

Ask questions about the World Cat power catamaran!
Evan
Posts: 93
Joined: Wed May 05, 2004 5:23 am
Boat Year: 2003
Boat Mfg: Worldcat
Boat Model: 230SF

BF130 problems

Postby Evan » Mon Jul 09, 2018 4:30 pm

I have 23' World cat with twin BF130's. My starboard engine is running 400 RPM (5600) slower then the Port.
I just changed the oil replaced the external FF and the internal Low pressure filter. It is also sluggish when
i throttle up. I don't run very much WOT and didn't notice it until I did the maintenance.

My Port engine runs 6000 RPM WOT but when I changed the oil it was way over full.
I read where it could be the thermostats. They were changed a couple of years ago.
What should I look at?
2003 - 230SF, Honda 130's, Garmin 1040XS

raduray
Posts: 39
Joined: Sun Jul 26, 2015 11:43 am
Boat Year: 2001
Boat Mfg: World Cat
Boat Model: 266 LC

Re: BF130 problems

Postby raduray » Fri Jul 13, 2018 3:09 pm

I no longer have my Hondas, but when I did, I found this forum very helpful:
http://www.marineengine.com/boat-forum/ ... oard-Forum
2001 World Cat 266LC Leisure Cat w/Mercury 150 Four Strokes

Patg
Posts: 82
Joined: Thu Sep 18, 2003 7:21 am
Boat Year: 1999
Boat Model: 266SC

Re: BF130 problems

Postby Patg » Sun Jul 15, 2018 5:13 pm

Sounds like bad gas issues. Change all the filters; isolate the starboard engine with a one gallon gas tank filled with gas and seafoam. Disconnect at engine at reconnect the temp gas can. Let it run on the earmuffs at idle for around an hour. Repeat procedure . My BF130 (starboard) had same issue and also ran sluggish at idle. If this does not do it, look at EFI system.....

dicksboat
Posts: 214
Joined: Wed Jun 18, 2003 9:16 pm
Boat Year: 1998
Boat Mfg: Former World Cat owner
Boat Model: Former owner 266SF

Re: BF130 problems

Postby dicksboat » Sun Jul 15, 2018 10:56 pm

I would check few things before messing with the fuel system and ignition . First check your tachometers . You can swap the tach signal wires to the other sides then run a test at full throttle and see if the readings stay the same or switch sides(tach problem). Do the engines sing the same sound at WOT or do you hear a varying tone indicating out of sync ?
Inspect both props for any slight imperfection particularly the cupped edge. Remove the props and look for fishing line fused around the shaft at the bearing. Check that the lower units are parallel with no toe in or out . Does the boat sit level at rest ? If different,the lower motor will be slower. Remove any cavitation plate tab zincs, if installed, for speed tests. Don't rely on the trim gauges for equal trim angles. Look at the engines to determine if at equal angles. With engines off, put both controls into full throttle and check for full cable and throttle movement at the engine by removing the cables from the throttle linkage studs. See if the cable ends and studs line up or have play at full throttle. Regarding the fuel systems, try swapping the fuel hoses to the engines and see if the problem moves over also. Pump the primer bulbs as hard as you can and look for a leak at the fuel line plugin (o-ring)to the engine. Check the hull gas tank vents for blockage or corrosion. Try loosening the gas cap and testing WOT. Are both gas cap o-rings in place ? Do you have any transducers that can disturb the water on one side ?

User avatar
DAY_OFF
Posts: 210
Joined: Tue Jul 12, 2005 11:05 pm
Boat Year: 2005
Boat Mfg: WORLDCAT
Boat Model: 250DC
Contact:

Re: BF130 problems

Postby DAY_OFF » Tue Jul 17, 2018 7:52 am

If you changed the oil and had the hood off, did you bump any wires loose, maybe a spark plug wire?
2005 250 DC, 150 Hondas, Garmin 741XS, Simrad AP16,
Sitex ADF, Icom 422, Canon Electric Downriggers


Return to “Cat Talk”

Who is online

Users browsing this forum: Bing [Bot] and 13 guests